[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn: Can't convert string from native encoding to 'UTF-8'

From: Ryan Schmidt <subversion-2009b_at_ryandesign.com>
Date: Fri, 9 Oct 2009 01:19:16 -0500

On Oct 9, 2009, at 00:22, J. Bakshi wrote:

> J. Bakshi wrote:
>>
>
>> I ahve found a problem in a new svn repo. When I did commit it
>> reports
>>
>> ````````````````````````````
>> Sending typo3conf/localconf.php
>> Transmitting file data .
>> Committed revision 11.
>>
>> Warning: post-commit hook failed (exit code 1) with output:
>> svn: Can't convert string from native encoding to 'UTF-8':
>> svn: ?\195?\160.wav
>> `````````````````````````````````````
>>
>> where the locale of my system ( suse 11) shows
>>
>> ```````````````````````
>> LANG=en_US.UTF-8
>> LC_CTYPE=en_US.UTF-8
>> LC_NUMERIC="en_US.UTF-8"
>> LC_TIME="en_US.UTF-8"
>> LC_COLLATE="en_US.UTF-8"
>> LC_MONETARY="en_US.UTF-8"
>> LC_MESSAGES=
>> LC_PAPER="en_US.UTF-8"
>> LC_NAME="en_US.UTF-8"
>> LC_ADDRESS="en_US.UTF-8"
>> LC_TELEPHONE="en_US.UTF-8"
>> LC_MEASUREMENT="en_US.UTF-8"
>> LC_IDENTIFICATION="en_US.UTF-8"
>> LC_ALL=
>> ````````````````````````````````````
>>
>> any clue ?
>>
>>
>
> Still suffering with this problem.
> Is there any server-side fix of this problem ?
> kindly enlighten me.

The locale variables you showed are on your client? I don't think that
wouldn't be relevant; it's the post-commit hook that's failing, so
it's the post-commit hook that needs the locale variables set properly
within it. (Remember that hook scripts run with an empty environment.)
What is the contents of your post-commit hook script?

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2405422

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-10-09 08:20:36 CEST

This is an archived mail posted to the Subversion Users mailing list.