[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Libtool warning svn 1.6.5

From: Stefan Sperling <stsp_at_elego.de>
Date: Wed, 7 Oct 2009 13:09:18 +0100

On Wed, Oct 07, 2009 at 04:58:29AM -0700, Alexandre Moraes wrote:
> Hi,
>
> I didn´t find an answer or if can be normal or not.
>
> During configure and make, I´m receiving this warning:
>
> libtool: link: warning:
> `/usr/lib/gcc/i586-suse-linux/4.1.2/../../..//libexpat.la' seems to be moved

This warning has nothing to do with svn.
You should see it with any software using libtool for compilation.

It just means that the libexpat.la script is now in a different
directory than the installation directory recorded by libtool
in the .la file. Looking into the .la file for a line starting
with "libdir=" might give some hints.

I guess this can happen if libraries are installed into a "fake" root
directory before being wrapped up in a packaging format like RPM.
The RPM will then install into the real root, causing the .la file
to appear at a different path (the "fake" root prefix is missing).

It's not a problem.

Stefan

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2404483

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-10-07 14:10:29 CEST

This is an archived mail posted to the Subversion Users mailing list.