[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Subversion 1.6.5 bindings for Perl 5.10 on Windows

From: Byron Hammond <bhammond_at_ccg.murdoch.edu.au>
Date: Thu, 01 Oct 2009 10:30:18 +0800

Hi all...

I've just managed to get a dynamically linked Subversion 1.6.5 built
and running on Windows. I now want to build the Perl bindings for my
Strawberry Perl 5.10.

I had problems during linking of the __SWIG_PERL__ project however as
Perl doesn't have perl510.lib. No probs I say, I'll just modify the
project files and replace perl510.lib for libperl510.a

perl -pli.bak -e 's/perl510\.lib/libperl510\.a/g' \
build/win32/vcnet-proj/*.vcproj

So now it builds, no errors, just heaps of warnings (hopefully benign).
I copy the .pm .dll .lib and .pdb files to the directories as specified
in the INSTALL file.

I go to run a small test script that works under linux and cygwin, but
when I get this message...

The procedure entry point _apr_time_ansi_put_at_12 could not be located
in the dynamic link library libapr-1.dll

I remembered having PATH issues earlier when testing svn.exe so I then
decided to prepend the directory containing all my dll lib and pdb
files to my PATH (apr,apr-iconv,apr-util,subversion). When I run the
same script again I get a dialog saying perl.exe has stopped working.

I prepended the lib dirs to my PATH because I didn't want it to find
libs installed from the binary installs of Apache 2.2 and Subversion
1.6.5. Apache 2.2 and Subversion dir were already in the path.

Eek! What to do? Anybody else built bindings for Strawberry 5.10?
Any and all help appreciated.

Byron

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2402351

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-10-01 04:31:19 CEST

This is an archived mail posted to the Subversion Users mailing list.