[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Unhelpful error message in Subversion

From: Ryan Schmidt <subversion-2009b_at_ryandesign.com>
Date: Wed, 24 Jun 2009 13:28:46 -0500

On Jun 24, 2009, at 06:31, Colin Fine wrote:

> While developing some scripts using the Subversion API, I
> encountered a
> not-very-obvious error message.
>
> Then I tried it from the command line, and found it was exactly the
> same.
>
> The circumstance is
> - I have a sandbox which is checked out from a branch
> - I issue 'svn update -r 1700', where revision 1700 happens to be
> before
> this branch was copied.
> - SVN replies "REPORT of '/svn/sources/!svn/vcc/default': 200 OK
> (http://svn.pace.internal)" which I take to be a WEBDAV status
> message.
>
> This is easily reproducible, and in my eyes is a bug. I've had a
> look in
> the bugzilla, but I'm not sure what to search for. I've had a
> google for
> it, but the cases being discussed are either not this particular
> one, or
> the people in question hadn't noticed that they were.
>
> svn, version 1.5.4 (r33841)
> compiled Oct 27 2008, 05:40:26

I get the same with 1.6.3 on Mac OS X 10.4.11. I agree it would be
nice to have a more-easily-understandable error message for this
failure.

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2365052

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-06-24 20:29:49 CEST

This is an archived mail posted to the Subversion Users mailing list.