[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

upgrade from 1.5.5 to 1.6.2 (svnadmin upgrade and pack)

From: Rob Crommentuijn <RCrommentuijn_at_adimec.nl>
Date: Mon, 8 Jun 2009 09:14:43 +0200

Dear all,

We upgraded our repo this weekend from Subversion 1.5.5 to 1.6.2. The
upgrade of the software went without a problem. After this upgrade I
wanted to update the "version" of the repo to the schema of 1.6.2.

I have done this using the following command: svnadmin upgrade
<path_to_repo/repo_name>. This was finished within 10 seconds (with a repo
size of 3,4gb). Afterwards I checked the contents of the following files,
<repo_name>/format and <repo_name>/format/db. The contents were for the
first file: 5 and the second file: 4 layout linear.

Afterwards I also did run the svnadmin pack <path_to_repo/repo_name>. This
did nothing, no output on the cli or else.

I have 2 questions, Is it normal that the upgrade is so fast? Why doesn't
the svnadmin pack command work?

Server specs and software
HP DL380G5 5120 1G EU svr
FreeBSD 6.2 I386 SMP
Intel Xeon 5120 1,86Ghz Dual Core
2GB (4x 512MB 533 FB-Dimms)
P600 Smart Array Controller 256MB
6x 146GB 10K SAS Raid 5 + Hotspare (Max Boot enabled) (effective 570GB)

Subversion 1.6.2 with FSDB

If you need any more information, just ask.

kind regards

Rob Crommentuijn

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2360207

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-06-08 09:17:03 CEST

This is an archived mail posted to the Subversion Users mailing list.