[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Weird SVNServe issues

From: Arthur Axel fREW Schmidt <frioux_at_gmail.com>
Date: Wed, 3 Jun 2009 09:43:48 -0500

Note: I originally posted this to the tortoise list, but this is more of a
server issue, so I am reposting it with corrections here.

Hey guys,

I am kinda at the end of my rope here; this is a very strange issue.

So one of my users was recently having issues commiting to SVN. He was
commiting *from* a shared checkout on a windows remote share. In the irc
channel someone told me that was problematic so we stopped using the remote
share and gave each person a local checkout, checked out with their users.

Whenever *anyone* checked out a new checkout from the repo they could not
check in and got an "Authorization failed" error. I verified the repo and
everything was fine. Next I did an svnadmin dump foo | svnadmin load bar.
After I did that I was forced to upgrade from our ghetto SVNServer to the
regular svnserve. That was fine. After that I could check out and check in
from the repo in question. My coworker still had issues. In fact, after we
checked in from his account, no one could check in. Oh, and I *did* rename
the
new built repo to the name of the original one.

As someone asked on the other ML, I am serving over svn://

Guys, I am totally at a loss here. Does anyone have any idea what could be
going on?

Thanks so much.

-- 
fREW Schmidt
http://blog.afoolishmanifesto.com
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=2359094
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-06-03 16:46:18 CEST

This is an archived mail posted to the Subversion Users mailing list.