[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Question regarding svn:externals and existing directories

From: Ryan Schmidt <subversion-2009a_at_ryandesign.com>
Date: Tue, 21 Apr 2009 07:05:55 -0500

On Apr 20, 2009, at 04:33, webpost_at_tigris.org wrote:

> The docs mention that the svn:externals target directory should not
> exist. I added this property to the root of my WC:
>
> http://framework.zend.com/svn/framework/standard/trunk/library/
> Zend_at_14980 library/Zend
>
> ... where the library directory existed, but not the Zend
> directory. Updating the WC (with Subclipse) did not check out the
> external project. Does the library directory also have to not exist?

I don't know. Try it out in a testing environment and see if that
fixes it.

The book says "subdirectories" (plural): "The relative target
subdirectories of externals definitions *must not* already exist"

http://svnbook.red-bean.com/en/1.5/svn.advanced.externals.html

> I added the external to the library directory itself (target:
> Zend), and it worked fine.

This is the only way I have ever used externals and it works fine, so
I recommend you do it that way.

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1842406

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-04-21 14:07:38 CEST

This is an archived mail posted to the Subversion Users mailing list.