[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Newbie Question

From: Programmer <prog_at_aogc.biz>
Date: Wed, 15 Apr 2009 10:05:45 -0500

Is the repo name in the authz file the same thing is what is created with
svnadmin create <repo name>? If so, then yes. My goal is to have a global
passwrd file and authz file. Is this not possible?

 

# this works for any user set up here, but won't this allow access for
anything in the default repository start folder, i.e. D:\Repositories\

[/]

test = test

 

# this is what I want. Repo specific permissions to particular repos for
particular users

[Project1:/] # project is located in D:\Repositories\Project\Project1

test = test

 

 

Thanks,

 

 

Jeremy

 

From: Bob Archer [mailto:Bob.Archer_at_amsi.com]
Sent: Wednesday, April 15, 2009 9:56 AM
To: Programmer; users_at_subversion.tigris.org
Subject: RE: Newbie Question

 

It all looks right to me. If you remove the repository name does it then
work? Svn is case sensitive. Are you sure "Project1" is the repo name?

 

BOb

 

 

  _____

From: Programmer [mailto:prog_at_aogc.biz]
Sent: Tuesday, April 14, 2009 6:20 PM
To: users_at_subversion.tigris.org
Subject: Newbie Question

 

I have successfully installed subversion on a Windows 2008 Server.

Client Tortoise SVN on Vista.

My root directory where I want to locate my repositories is D:\Repositories

I have created a repository called D:\Repositories\Projects\Project1

 

Config Files are as follows:

 

svnserve.conf

[general]

anon-access = none

auth-access = write

password-db = //./D:/Repositories/auth/passwrd

authz-db = //./D:/Repositories/auth/authz

....

 

passwrd

[users]

test = test

 

authz

#give all read access to all repos

[/]

* = r

 

#give test write access to repo Project1

[Project1:/]

test = rw

 

My problem is everything works except that I can not commit any changes
back. If I change the authz to [/] * = rw, I can do everything. Am I not
accessing the repo right in the second declaration in the authz file? I
have tried everything from absolute to relative pathing. What am I doing
wrong?

 

Any help would be appreciated.

 

Thanks,

 

 

Jeremy Schreckhise, M.B.A., B.S., MCP

Director of Information Technology

 

Arkansas Oklahoma Gas Corp.

115 N. 12th Street

Fort Smith, AR 72901

479-783-3181 ext. 2259

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1728341

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-04-15 17:06:34 CEST

This is an archived mail posted to the Subversion Users mailing list.