[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Perl API Question: svn_client_update3 is not implemented yet

From: Eric Peers <peers_at_mtnboy.net>
Date: Tue, 14 Apr 2009 18:14:04 -0600

First of all, let me say thank you - I have used subversion for a couple
of projects and I find it quite useful.

I've been developing some C code and some corresponding perl code using
Subversion's direct API (I found it to be 2-3x faster than commandline
svn, in some cases 4-6x). On an FC10 box with svn version 1.5.4, and the
corresponding perl rpm's installed, I can successfully call and use
"update3":
   
    #file, rev, depth, depth is sticky, ignore_externals,
allow_unver_obstructions
    #depth = 0 => empty, 3 => infinity
    $self->{ctx}->notify(\&_update_printer);
    $self->{ctx}->update3('', 'HEAD', 3, 1, 1, 0);

This code does not work on a hand-built subversion 1.6.1 build on Centos
5.2 (I needed to target an NFS mounted perl binary). I get the following
error message:
ValueError svn_client_update3 is not implemented yet

I used swig 1.3.36 to generate svn_client.c

Any thoughts on why this might be? Is there a fast and loose switch I
can throw to get it running?

Thanks!
   --Eric

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1718200

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-04-15 02:43:04 CEST

This is an archived mail posted to the Subversion Users mailing list.