[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 'make check' Failures, v 1.6.0, x86_64, Centos 5.2

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 2 Apr 2009 13:30:49 +0100

On Thu, Apr 02, 2009 at 01:22:39PM +0100, Stefan Sperling wrote:
> On Thu, Apr 02, 2009 at 06:15:18AM -0500, Tom Browder wrote:
> > On Wed, Apr 1, 2009 at 6:28 PM, Tom Browder <tom.browder_at_gmail.com> wrote:
> > > On Wed, Apr 1, 2009 at 4:19 PM, Stefan Sperling <stsp_at_elego.de> wrote:
> > > ...
> > >>> >> I can attach the test log if there is interest.
> >
> > I have attached the tests.log as compressed by bzip2. I hope someone
> > can find an obvious problem. I have done a clean build and 'make
> > check' again with the same results.
>
> This is your problem:
>
> /disk3/extsrc/subversion-1.6.0-pkgs/subversion-1.6.0/subversion/tests/libsvn_fs/
> .libs/lt-fs-test: symbol lookup error:
> /disk3/extsrc/subversion-1.6.0-pkgs/subversion-1.6.0/subversion/libsvn_subr/.libs/libsvn_subr-1.so.0: undefined symbol: apr_hash_clear
>
> Your Subversion binaries and libraries are not picking up the right
> libraries they depend on. Check them with ldd.
>
> You should deinstall any prevision Subversion libraries you might

I meant to say 'previous', sorry if this was confusing.
Subversion does not have 'vision' yet :)
 
Stefan
Received on 2009-04-02 14:31:46 CEST

This is an archived mail posted to the Subversion Users mailing list.