[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Windows drive root commit bug still present

From: <webpost_at_tigris.org>
Date: Wed, 1 Apr 2009 23:55:50 -0700 (PDT)

I thought this was supposed to be getting fixed for 1.6.0? It has plagued me all throughout 1.5.x and I was told that it would be resolved in 1.6...

In case you can't remember the original report: the problem occurs when the working copy is at the root of a Windows drive (a SUBST drive, in my case) and files are chosen from multiple subfolders to be committed. (Committing files from each folder individually works, but is ugly.)

(Error dialog from TSVN follows.)

---------------------------
Subversion Exception!
---------------------------
Subversion encountered a serious problem.
Please take the time to report this on our mailing list with as much information as possible about what you were trying to do.

Subversion reported the following:

In file
'D:\nightlybuilds\1.6.x\TortoiseSVN\ext\subversion\subversion\libsvn_client\commit.c'
line 1512: assertion failed ((target[0] != '\0') && !svn_dirent_is_root(target, strlen(target)))
---------------------------
OK
---------------------------

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1515048

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-04-02 13:46:39 CEST

This is an archived mail posted to the Subversion Users mailing list.