[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Memory usage 1.5.5

From: Adrian Marsh <Adrian.Marsh_at_ubiquisys.com>
Date: Tue, 24 Feb 2009 15:14:09 -0000

Hi Mark,

Well I did do a yum update at the same time to ensure dependancies were all there. Checking the logs I can see httpd was updated, by a point release to 2.2.3-22.el5

Config files stayed the same though, mod_dav_svn did try to edit subversion.conf, but I put the original back.

Below is a list of the modules. I need LDAP,SSL and SVN and probably vhost the rest I'm not sure about.

Do you know which ones might of caused trouble??

LoadModule auth_basic_module modules/mod_auth_basic.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_alias_module modules/mod_authn_alias.so
LoadModule authn_anon_module modules/mod_authn_anon.so
LoadModule authn_dbm_module modules/mod_authn_dbm.so
LoadModule authn_default_module modules/mod_authn_default.so
LoadModule authz_host_module modules/mod_authz_host.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_default_module modules/mod_authz_default.so
LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
LoadModule env_module modules/mod_env.so
LoadModule ext_filter_module modules/mod_ext_filter.so
LoadModule mime_magic_module modules/mod_mime_magic.so
LoadModule expires_module modules/mod_expires.so
LoadModule deflate_module modules/mod_deflate.so
LoadModule headers_module modules/mod_headers.so
LoadModule usertrack_module modules/mod_usertrack.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule mime_module modules/mod_mime.so
LoadModule dav_module modules/mod_dav.so
LoadModule status_module modules/mod_status.so
LoadModule autoindex_module modules/mod_autoindex.so
LoadModule info_module modules/mod_info.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule vhost_alias_module modules/mod_vhost_alias.so
LoadModule negotiation_module modules/mod_negotiation.so
LoadModule dir_module modules/mod_dir.so
LoadModule actions_module modules/mod_actions.so
LoadModule speling_module modules/mod_speling.so
LoadModule userdir_module modules/mod_userdir.so
LoadModule alias_module modules/mod_alias.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_balancer_module modules/mod_proxy_balancer.so
LoadModule proxy_ftp_module modules/mod_proxy_ftp.so
LoadModule proxy_http_module modules/mod_proxy_http.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule cache_module modules/mod_cache.so
LoadModule suexec_module modules/mod_suexec.so
LoadModule disk_cache_module modules/mod_disk_cache.so
LoadModule file_cache_module modules/mod_file_cache.so
LoadModule mem_cache_module modules/mod_mem_cache.so
LoadModule cgi_module modules/mod_cgi.so
LoadModule version_module modules/mod_version.so

-----Original Message-----
From: Mark Phippard [mailto:markphip_at_gmail.com]
Sent: 24 February 2009 14:55
To: Adrian Marsh
Cc: users_at_subversion.tigris.org
Subject: Re: Memory usage 1.5.5

On Tue, Feb 24, 2009 at 9:50 AM, Adrian Marsh
<Adrian.Marsh_at_ubiquisys.com> wrote:

> I had a RHEL5 server quite happily running subversion 1.4 (via Apache) with
> no issues I could see.  We upgraded to 1.5 (.1 and now .5), and now the
> httpd process is a memory-grabbing monster that kills the system.  The
> server originally had only 1Gb of memory, and I've ordered 4Gb more, but is
> this a known issue with 1.5 ?

Did you change anything else? IOW, are you using the same Apache
server version and same httpd.conf? I've seen problems with certain
Apache modules being loaded causing problems. Even when you are not
specifically using these modules. Removing all modules you are not
using from the conf can sometimes help.

-- 
Thanks
Mark Phippard
http://markphip.blogspot.com/
------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1221126
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-24 16:15:41 CET

This is an archived mail posted to the Subversion Users mailing list.