[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Performance Issue/Hang with 1.5 svnserve

From: Emin.shopper Martinian.shopper <emin.shopper_at_gmail.com>
Date: Tue, 10 Feb 2009 17:14:29 -0500

Thanks for the quick response.

I tried with CollabNet version 1.5.4, version 1.4, and also with the
sliksvn you just suggested (all on the server). I am running the
server via "svnserve.exe -d --root <myRoot>". All seem to be pretty
slow.

I tried downloading Wireshark, but I haven't used that before and
didn't know how to get it to listen to the right thing.

Any help would be appreciated as waiting for superslow svnserve is very painful.

Thanks,
-Emin

On Tue, Feb 10, 2009 at 4:40 PM, Jason Malinowski <jason_at_jason-m.com> wrote:
> What 1.5 package are you running svnserves from? I run an svnserve on
> Windows downloaded from http://www.sliksvn.com/en/download and have not had
> the issues I saw with my built version on Ubuntu.
>
> Can you watch what's happening with Wireshark or other network tracer? The
> problem was clear it was a server issue since it would always pause here:
>
> ... ( success ( ( CRAM-MD5 ) 16:XXXXXXXX XXXXXXX ) ) ( CRAM-MD5 ( ) )
>
> Do you see that same behavior?
>
> Jason Malinowski
>
>
>> -----Original Message-----
>> From: Emin.shopper Martinian.shopper [mailto:emin.shopper_at_gmail.com]
>> Sent: Tuesday, February 10, 2009 3:30 PM
>> To: Jason Malinowski
>> Cc: Marshall White; users_at_subversion.tigris.org
>> Subject: Re: Performance Issue/Hang with 1.5 svnserve
>>
>> I'm having similar problems with svnserve, but my repository is on a
>> windows machine. Is there a way to speed up svnserve without having to
>> recompile APR on windows? Recompiling on windows can be a real pain
>> especially if you don't have the required compilers.
>>
>> Thanks,
>> -Emin
>>
>> On Sun, Aug 31, 2008 at 2:33 PM, Jason Malinowski <jason_at_jason-m.com>
> wrote:
>> > That looks like it's it. So my fault for not reading the FAQ. ;-)
>> >
>> > Jason Malinowski
>> >
>> >
>> > -----Original Message-----
>> > From: Marshall White [mailto:marshall.white_at_pobox.com]
>> > Sent: Saturday, August 30, 2008 11:04 AM
>> > To: Jason Malinowski
>> > Cc: users_at_subversion.tigris.org
>> > Subject: Re: Performance Issue/Hang with 1.5 svnserve
>> >
>> > From: "Jason Malinowski"
>> > Sent: Wednesday, August 27, 2008 10:08 AM
>> > To: "'Mark Phippard'"
>> > Cc: <users_at_subversion.tigris.org>
>> > Subject: RE: Performance Issue/Hang with 1.5 svnserve
>> >
>> >>> Mark: My first guess would be that you have a post-commit hook that
>> > is
>> >>> running and needs to be adjusted for the SVN 1.5 paths or upgrade.
>> >>> I'd look at that first.
>> >>
>> >> The SVN dump was loaded into a clean 1.5 repository. There are no
>> > hooks
>> >> being used.
>> >>
>> >> And an obvious thing I forgot to say in my last post: I'm running
>> >> Subversion 1.5.1.
>> >>
>> >> Jason Malinowski
>> >>
>> >>
>> >
>> > Maybe you ran into this:
>> > http://subversion.tigris.org/faq.html#slow-private-svnserve
>> >
>> >
>> > Marshall
>> >
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: users-unsubscribe_at_subversion.tigris.org
>> > For additional commands, e-mail: users-help_at_subversion.tigris.org
>> >
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: users-unsubscribe_at_subversion.tigris.org
>> > For additional commands, e-mail: users-help_at_subversion.tigris.org
>> >
>> >
>
>

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1136274

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-10 23:16:14 CET

This is an archived mail posted to the Subversion Users mailing list.