[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

endless(?) loop with heavy io when doing a svn move

From: AmenophisIII <AmenophisIII_at_gmx.at>
Date: Fri, 6 Feb 2009 05:45:15 +0100

hoi!

im using subversion 1.5.1 on ubuntu 8.10 (64bit).
i have a file that seems to hang svn when i try to rename it. i always
tried to kill svn, so im not 100% sure its really an endless loop or
just a really long and stupid loop. :)
even when hitting ctlr+c a few seconds after entering the command, when
io goes up, it takes several minutes (more than 5) on my core2 dual core
to actually stop(!). xserver and alsa output get totally blocked
in the meantime, keyboard "works" (num led switching).

im not sure what i did exactly before this. some other svn
moving/refactoring of my src tree.
the behaviour is fixed after i (cleanup and) commit, but it should get
fixed nontheless imho :)

i have tared the directory (including the .svn dir) and can reproduce
the behaviour when untaring it somewhere else.
im not sure if it is safe to share it due to authentification data
caching (guess not?). at least the url of the rep is in there, which i
dont wanna share anyway.
can i get rid of that information without killing the bug trigger?

(pls reply via email too, im not subscribed.)

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1110604

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-06 05:46:44 CET

This is an archived mail posted to the Subversion Users mailing list.