[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: "svn: Authorization failed"; what am I doing wrong?

From: Troy Watson <drtwox_at_gmail.com>
Date: Tue, 3 Feb 2009 17:47:27 +1000

> Bob Archer wrote:
> Did you try to pass your --username drtwox --password password
> On your import command line?

Yeah, I tried that, still the same error.

> Hari Kodungallur
>...but I believe it should be something like:
>[svn:projects/]
>That is, the header has two elements. The left side is the name of the
>repository and the right side is the path within that repository.

Is the 'realm' in svnserve.conf the 'name of the repository'? I'm
unsure of what you're suggesting I should do. Is this what you mean?
(Using the same svnserve.conf as my original post):

drtwox_at_server:~$ cat svn/conf/authz
[projects:] (As I want full access to the svn root)
drtwox = rw

I tried that, still the same "Authorization failed" error. I also
tried a blank authz file, same error again. The following also...
same error.

drtwox_at_server:~$ cat svn/conf/authz
[/home/drtwox/svn]
drtwox = rw

So frustrating... Thanks for the help so far though!

------------------------------------------------------
http://subversion.tigris.org/ds/viewMessage.do?dsForumId=1065&dsMessageId=1095346

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_subversion.tigris.org].
Received on 2009-02-03 14:34:47 CET

This is an archived mail posted to the Subversion Users mailing list.