[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn v1.5.1 via apache 2.0.63 on solaris "Final line in revision file longer than 64 characters"

From: Mark Phippard <markphip_at_gmail.com>
Date: Thu, 14 Aug 2008 10:21:20 -0400

On Thu, Aug 14, 2008 at 10:17 AM, Steve Whitson
<steven.whitson_at_gmail.com> wrote:

> I've not gotten any response to my minimum version question (subject "what
> apache version is acceptable with subversion 1.5.1)... and have been
> relegated to using v1.4.6 with apache 2.0.63. I only saw one place where
> any reference to v1.5.0 was made with apache 2.0.x, and that was a pre-built
> binary for windows, not exactly useful since I'm needing a solaris target.
> I think we'd certainly encourage using the latest 2.0.x version, but
> AFAIK, the minimum version is the same as it always has been.
> Something like 2.0.49? It is mentioned in INSTALL:
> http://svn.collab.net/repos/svn/branches/1.5.x/INSTALL
> That was the premise I was working from... but couldn't get things to work
> (couldn't get svn 1.5.1 to work on apache v2.0.63) as noted in this message
> thread. I also worked to move up to apache 2.2.x (now 2.2.9) and found a
> roadblock replacing my mod_auth_mysql security piece using either the
> mod_auth_mysql patch (for apache 2.2.x) or the now supported mod_authn_dbd
> module (problems which I pursued on the apache forum).
> Giulio mentioned (was under the impression) that svn 1.5.1 requires apache
> 2.2.x (also noted in this thread). I've dug around for documentation
> substantiating this, but to no avail. The INSTALL text file you mention is
> the only reference I can locate. There's a bit more details I found wrt
> prepackaged binarys (from collabnet) and apache versions included with them
> in my other message (subject: what apache version is acceptable with
> subversion 1.5.1).

I can answer that part definitively for you. Apache 2.2 is absolutely
not a requirement. Obviously there will be various things that are
fixed in Apache 2.2 and not 2.0, but other than better support for
files > 2GB, there should be no hard and fast reasons you have to use

The CollabNet binaries are all built using Apache 2.2.

Mark Phippard
To unsubscribe, e-mail: users-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: users-help_at_subversion.tigris.org
Received on 2008-08-14 16:21:48 CEST

This is an archived mail posted to the Subversion Users mailing list.

This site is subject to the Apache Privacy Policy and the Apache Public Forum Archive Policy.