[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: crash issue svn 0.9.6 / subversion 1.4.6

From: Ryan Schmidt <subversion-2008b_at_ryandesign.com>
Date: Wed, 16 Apr 2008 11:13:50 -0500

On Apr 16, 2008, at 8:03 AM, ANDREW.LUCAS_at_L-3Com.com wrote:
> I have the following setup:
> server: subversion 1.4.2
> pc: subversion 1.4.2, rapidsvn 0.9.6
>
> With that setup, things work fine.
>
> If I upgrade the pc subversion to 1.4.6 (svnserve on server still
> 1.4.2) then rapidsvn 0.9.6 on the pc gets a crash dialog on its
> startup. The OS is Windows XP. I'm using the install scripts from
> the normal distribution download.
>
> If I go back to 1.4.2 on the pc, then things work again.
>
> Is this because the local pc subversion needs to match the server
> subversion?

No, any 1.x verison of a Subversion server should be able to
communicate with any 1.x version of a Subversion client.

> It looks like the subversion on the pc is running otherwise. I
> didn't try any repository manipulation, but it has the svn help /
> svnadmin help without problems.
> I would have thought all those versions should have played together
> ok.
> There is a subversion download for apache 2.2 and 2.0. I think I
> grabbed the 2.2 version. We aren't using apache, just svnserve. I
> didn't try the other one (pesky work got in the way).
>
> I haven't reviewed the message board history yet, so apologies if
> this is a repeat.

You might want to ask on the rapidsvn mailing list, since your
problem seems to be with rapidsvn.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe_at_subversion.tigris.org
For additional commands, e-mail: users-help_at_subversion.tigris.org
Received on 2008-04-16 18:14:59 CEST

This is an archived mail posted to the Subversion Users mailing list.