[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: to devs: please provide binaries for 1.5-beta

From: Stefan Sperling <stsp_at_elego.de>
Date: Thu, 3 Apr 2008 15:12:56 +0200

On Thu, Apr 03, 2008 at 02:59:55PM +0200, Lustig, Marc (Allianz Deutschland AG) wrote:
> ok, sure, here are the details:

What you are reporting is not a bug in the configure script,
as you claimed in your first mail.

Based on the error below, I guess you need to either install the
zlib-dev package (this is the easy way), or compile your custom
zlib with -fPIC as indicated in the error message you got.

> - Linux version 2.6.18-5-amd64 (Debian 2.6.18.dfsg.1-13etch4)

The kernel version does not matter at all here.

> - followed instructions from INSTALL file
> - installed zlib 1.2.3 from source (download from zlib.net)
> - ./configure runs successfully

Did you really run
        ./configure

here, or did you pass additional parameters?

> - make breaks with following result:
>
> ...
> ------ completed all in neon
> cd subversion/libsvn_subr && /bin/sh /home/subversion/download/subversion-1.5.0-beta1/libtool --tag=CC --silent --mode=link gcc -g -O2 -g -O2 -pthread -rpath /usr/local/lib -o libsvn_subr-1.la atomic.lo auth.lo cmdline.lo compat.lo config.lo config_auth.lo config_file.lo config_win.lo constructors.lo ctype.lo date.lo dso.lo error.lo hash.lo io.lo iter.lo kitchensink.lo lock.lo md5.lo mergeinfo.lo nls.lo opt.lo path.lo pool.lo prompt.lo properties.lo quoprint.lo simple_providers.lo sorts.lo ssl_client_cert_providers.lo ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo stream.lo subst.lo svn_base64.lo svn_string.lo target.lo time.lo user.lo username_providers.lo utf.lo utf_validate.lo validate.lo version.lo win32_crashrpt.lo win32_xlate.lo xml.lo /home/subversion/download/subversion-1.5.0-beta1/apr-util/libaprutil-1.la /home/subversion/download/subversion-1.5.0-beta1/apr-util/xml/expat/lib/libexpat.la /home/subversion/download/subversion-1.5.0-beta1/apr/libapr-1.la -lrt -lcrypt -lpthread -ldl -lz
> /usr/bin/ld: /usr/local/lib/libz.a(deflate.o): relocation R_X86_64_32S against `a local symbol' can not be used when making a shared object; recompile with -fPIC
> /usr/local/lib/libz.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
> make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1
>
>
> tried also installing zlib using apt-get (package zlib-bin)
> tried also ./configure --enable-shared

-- 
Stefan Sperling <stsp_at_elego.de>                 Software Developer
elego Software Solutions GmbH                            HRB 77719
Gustav-Meyer-Allee 25, Gebaeude 12        Tel:  +49 30 23 45 86 96 
13355 Berlin                              Fax:  +49 30 23 45 86 95
http://www.elego.de                 Geschaeftsfuehrer: Olaf Wagner

  • application/pgp-signature attachment: stored
Received on 2008-04-03 15:13:25 CEST

This is an archived mail posted to the Subversion Users mailing list.