[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: SVN 1.4.4 PROPFIND error and Apache 2.2 SEGFAULT

From: Southern, Jason <southern_jason_at_bah.com>
Date: 2007-08-28 23:39:43 CEST

I just saw that Apache 2.2.4 is recording a 401 Unauthorized error in
the access_log:

127.0.0.1 - - [28/Aug/2007:16:40:15 -0400] "PROPFIND /repos/esd
HTTP/1.1" 401 401

This occurs when I type in the correct password for my account in
htpasswd. However, when I type the wrong password this appears in the
error_log:

[Tue Aug 28 17:31:24 2007] [error] [client 127.0.0.1] user jsouthern:
authentication failure for "/repos/esd": Password Mismatch

I tried recreating the htpasswd file using SHA1 for encryption rather
than MD5. No change in outcome.

I'm willing to run gdb on httpd, but I don't know the mod_dav_svn method
on which I should set a breakpoint.

Jason

-----Original Message-----
From: Southern, Jason [mailto:southern_jason@bah.com]
Sent: Tuesday, August 28, 2007 4:44 PM
To: users@subversion.tigris.org
Subject: SVN 1.4.4 PROPFIND error and Apache 2.2 SEGFAULT

I've installed Apache 2.2 and SVN 1.4.4 on Solaris 10 using SMC
libraries from sunfreeware.com. Apache is loading mod_dav before loading
mod_dav_svn and mod_authz_svn. I have this location declared in the
configuration file:

<Location /repos>
    DAV svn
    SVNParentPath /opt/svnrepos
    SVNListParentPath on
    AuthType Basic
    AuthName "Subversion repositories"
    AuthUserFile /etc/svn-auth-file
    Require valid-user
</Location>

When attempting to access the repository through a web browser, the
connection is closed and this appears in the Apache error_log:

[notice] child pid 21863 exit signal Segmentation fault (11), possible
coredump in /usr/local/apache2

I also configured mod_dav_svn in httpd.conf to log to a custom log file,
but nothing is appearing in the log. Here is the Apache directive I'm
using:

CustomLog logs/svn_log "%t %u %{SVN-ACTION}e" env=SVN-ACTION

I next attempted to execute a svn import using the Solaris CLI. This is
the result:

> svn import sample-proj http://localhost:9999/repos/esd -m "initial
import"
svn: PROPFIND request failed on '/repos/esd'
svn: PROPFIND of '/repos/esd': Could not read status line: connection
was closed by server. (http://localhost:9999)

This seems like a problem the Subversion install and not Apache 2.2. Any
ideas of what the problem is or what I should investigate next?

Thanks,
Jason Southern

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Aug 28 23:37:27 2007

This is an archived mail posted to the Subversion Users mailing list.