[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

AW: svnlook problem with unicode utf8 under windows

From: Jendro, Carsten (SAZ-DE) <CJendro_at_saz.net>
Date: 2007-08-02 16:48:39 CEST

!!! Update: added some line breaks.

Hi All,

I have a problem with svnlook. I don't get any Unicode or utf8 output
from this Tool.

I have written a pre-commit hook under windows that changes the log
message.

pre-commit.bat calls svnlook log ....... >temp.txt

I have set this in my batch file.

->snip<----------------------------------

set APR_ICONV_PATH=C:\Programme\CollabNet Subversion
Server\httpd\bin\iconv

set LANG=de_DE.UTF8

mode con codepage select=?????

->snip<----------------------------------

I have tested a lot of different codepages here, but I found no way to
tell svnlook to use utf-8 or unicode.

I have tested a dirty trick, I have copied the file utf-8.so to
cp65001.so and set the windows codepage to 65001 (mode con codepage
select=65001).

This works fine, svnlook puts out Unicode now, but I am not whure if it
really works correct in all cases. And it is a really dirty trick ;-)

Is there a clean way to get Unicode output from svnlook?

Thanx,

Carsten

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Aug 2 16:47:17 2007

This is an archived mail posted to the Subversion Users mailing list.