[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Performance problems: caused by LDAP authentication?

From: Tony Butt <tjb_at_cea.com.au>
Date: 2007-06-29 03:01:35 CEST

Hi,
We had similar problems with mod_auth_ldap, also with mod_auth_krb
(which can also authenticate to Active Directory)

Our server is a SLES 9 nox running apache 2.0.49 - we had to give up
mod_auth_ldap, as it kept breaking our server. I think things are better
with apache 2.2

I certainly found that ldap caching helped performance.
Our current solution is to use mod_auth_pam, and use pam + winbind on
the server to do the authentication. This is as good as we could get,
and is robust. It is still too slow. The fast access we have is to use
the svn+ssh protocol, which also uses the same pam+winbind setup.

Tony Butt
CEA Technologies
Canberra, Australia

On Thu, 2007-06-28 at 16:50 +0200, Banzi Massimo wrote:
> Hello all
>
> We have performance problems that seem to be due to the use of a
> “Windows 2000 Active Directory” LDAP server.to authenticate users on
> svn
>
> Here are the details:
>
> We use svn version 1.4.2 (r22196) installed on a Solaris 9 Sun Fire
> 15000 partition, biprocessor and with 8 GB RAM
>
> Apache 2.0.59 uses a mm_mod_auth_ldap module compiled with options:
>
> --with-mem-cache --with-apxs --with-apache-ver=2 --with-ssl=yes …….
>
>
>
> We installed an ALM tool POLARION that uses subversion as a repository
> and apparently enabling authentication on LDAP causes a delay of about
> 70% more than without LDAP.
>
> At the very beginning we thought the causes to be searched in
> POLARION, but they said that the authentication mechanism in POLARION
> relies all on svn authentication.
>
> The intensive use that POLARION does of authentication mechanism
> result in a delay which is unacceptable.
>
> You see that we also cached authentication in mm_mod__auth_ldap but
> apparently this is ininfluent.
>
>
>
> My questions are:
>
> did someone of you experience similar problems?
>
> Do you thing that we have something misconfigured?
>
> Moreover It seems that caching mechanism for auth_ldap module does not
> works!
>
> Have you any Idea?
>
>
>
> Thank You in advance
>
> Massimo
>
>
> --------------------------------------------------------------------
> CONFIDENTIALITY NOTICE
> This message and its attachments are addressed solely to the persons
> above and may contain confidential information. If you have received
> the message in error, be informed that any use of the content hereof
> is prohibited. Please return it immediately to the sender and delete
> the message. Should you have any questions, please contact us by
> replying to webmaster@telecomitalia.it.
> Thank you
> www.telecomitalia.it
> --------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jun 29 03:03:26 2007

This is an archived mail posted to the Subversion Users mailing list.