[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: compiling subversion with neon <> 0.25.5

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2007-06-12 00:28:43 CEST

On 6/11/07, Kendall Shaw <queshaw@pacbell.net> wrote:
> Erik Huelsmann wrote:
> > On 6/11/07, andreas.kollenbach@t-mobile.at
> > <andreas.kollenbach@t-mobile.at> wrote:
> >>
> >> Hello,
> >>
> >> i tried to compile subversion 1.4.3 with a newer neon library than
> >> version
> >> 0.25.
> >> But the config script insists on version 0.25.5.
> >>
> >> What's the reason for that behavior?
> >> Is there any incompatibility between a lib > 0.25.5 and subversion?
> >
> > Yes: from the Neon site: "The neon API is subject to
> > backwards-incompatible change over minor versions (0.24.x -> 0.25.x)
> > but is stable across patch releases (0.24.0 -> 0.24.x)."
> >
> > This means that new minor releases need to be explicitly verified to
> > be backward compatible, or the sources need to be adjusted for the new
> > version...
>
> I notice that the INSTALL file says you need 0.25.5 or 0.26.1. So,
> shouldn't that mean that the latest neon is compatible?

Yes, it does mean that. We have had problems in the past with new neon
versions so that we turned to a strategy where every release was
blessed separately. We currently haven't backported the 0.26.3
blessing to the 1.4 branch. I don't expect problems however.

bye,

Erik.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Jun 12 00:29:02 2007

This is an archived mail posted to the Subversion Users mailing list.