[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: compiling subversion with neon <> 0.25.5

From: Erik Huelsmann <ehuels_at_gmail.com>
Date: 2007-06-11 15:54:27 CEST

On 6/11/07, andreas.kollenbach@t-mobile.at
<andreas.kollenbach@t-mobile.at> wrote:
>
> Hello,
>
> i tried to compile subversion 1.4.3 with a newer neon library than version
> 0.25.
> But the config script insists on version 0.25.5.
>
> What's the reason for that behavior?
> Is there any incompatibility between a lib > 0.25.5 and subversion?

Yes: from the Neon site: "The neon API is subject to
backwards-incompatible change over minor versions (0.24.x -> 0.25.x)
but is stable across patch releases (0.24.0 -> 0.24.x)."

This means that new minor releases need to be explicitly verified to
be backward compatible, or the sources need to be adjusted for the new
version...

HTH,

Erik.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Jun 11 15:54:54 2007

This is an archived mail posted to the Subversion Users mailing list.