[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: anyone else seen this assertion error?

From: Rick Jones <rick.jones2_at_hp.com>
Date: 2007-06-02 01:45:45 CEST

Karl Fogel wrote:
> Rick Jones <rick.jones2@hp.com> writes:
>
>>OK, well, assuming I can swallow my fears of toasting the netperf.org
>>netperf source repositories is there a script I can follow to install
>>TOT over top of what I've got apt-got (as it were)? I'm ass-u-me-ing
>>that the place I want to run TOT is on the server rather than the
>>client?
>
>
> Operate on a copy of the repositories, not the originals! :-)

True - tahnkfully my "sandbox" repos is throw-away, and I can see the
problem with it.

>
> I'd install on a completely different machine, if you can.

wod that I had another pa-risc linux system for the server and x86 for
the client.

I just checked-out the latest TOT and built it but didn't do the make
install. In the past when I would do that (on HP-UX at least, I've
always "apt-got" on Debian) I could run ./subversion/svn/svn but here it
seems I cannot:

raj@tardy:~/svn_tot$ ./subversion/svn/svn --version
svn: Version mismatch in 'svn_delta': found 1.5.0-dev, expected 1.2.3
svn: Version mismatch in 'svn_subr': found 1.5.0-dev, expected 1.2.3
raj@tardy:~/svn_tot$ ./subversion/svn/svn --help
svn: Version mismatch in 'svn_delta': found 1.5.0-dev, expected 1.2.3
svn: Version mismatch in 'svn_subr': found 1.5.0-dev, expected 1.2.3
raj@tardy:~/svn_tot$ pwd
/home/raj/svn_tot
raj@tardy:~/svn_tot$ ./subversion/svn/svn co
http://www.netperf.org/svn/sandbox /tmp/sandbox_latest_client
svn: Version mismatch in 'svn_delta': found 1.5.0-dev, expected 1.2.3
svn: Version mismatch in 'svn_subr': found 1.5.0-dev, expected 1.2.3
raj@tardy:~/svn_tot$ which svn_delta
raj@tardy:~/svn_tot$ which svn_subr
raj@tardy:~/svn_tot$ pwd
/home/raj/svn_tot
raj@tardy:~/svn_tot$ export PATH=/home/raj/svn_tot/subversion/svn:$PATH
raj@tardy:~/svn_tot$ which svn
/home/raj/svn_tot/subversion/svn/svn
raj@tardy:~/svn_tot$ svn help
svn: Version mismatch in 'svn_delta': found 1.5.0-dev, expected 1.2.3
svn: Version mismatch in 'svn_subr': found 1.5.0-dev, expected 1.2.3

Could this be related to my trying to run the "new" svn command while in
a directory that was created with an older version of the client?

rick jones
>
> If the only place you can reproduce this right now is your current
> working copy, then save that working copy first thing. Try to use it,
> or rather a copy of it, for further reproduction.
>
> (Sorry, I know you're sort of asking for detailed instructions, and I
> don't have time to give them, unfortunately, but if there's a
> developer or Subversion admin around they'll probably know how to
> help...)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sat Jun 2 01:46:09 2007

This is an archived mail posted to the Subversion Users mailing list.