[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Difficulty bringing up apache after installing Subversion.

From: David Tyler <dtyler_at_justicesystems.com>
Date: 2007-04-19 21:56:02 CEST

>>>> Glenn R Heard Jr <gheard@neo.rr.com> 4/19/2007 01:24 PM >>>
>David Tyler wrote:
>> First I Installed apache and it appeared to be working.
>> After installing Subversion and setting up httpd.conf as directed, I receive the following error when I try to start apache:
>>
>> httpd: Syntax error on line 53 of /usr/local/apache2/conf/httpd.conf: Cannot load /usr/local/apache2/modules/mod_dav_svn.so into server: >/usr/local/apache2/modules/mod_dav_svn.so: undefined symbol: dav_xml_get_cdata
>>
>
>Are you also loading mod_dav.so before the mod_dav_svn.so?

It appears that mod_dav.so is missing from my installation of Subversion. This object is not included in the apache2 modules directory and the httpd.conf contains the following lines:

# LoadModule foo_module modules/mod_foo.so
LoadModule dav_svn_module modules/mod_dav_svn.so
LoadModule authz_svn_module modules/mod_authz_svn.so

-- 
Glenn R Heard Jr        gheard  _at_ neo.rr.com
ICQ: 123194600          grheard _at_ gmail.com
Y!: glennheard
---
In the beginning the universe was created. This made a lot of
people angry and has been widely regarded as a bad move
                               -- Hitchhikers Guide to the Galaxy
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Apr 19 21:56:51 2007

This is an archived mail posted to the Subversion Users mailing list.