[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Subversion Compilation Problem on Solaris 10 With Apache 2.2.4 - Dreadful libexpat!

From: Moudry, Mipam <mipam.moudry_at_medtronic.com>
Date: 2007-04-05 14:31:19 CEST

Hi All,
After spending another workday trying to figure out what is happening, I
have tried to uninstall the expat solaris package I got from
sunfreeware. Now when I try to compile Subversion 1.4.3 agaist apache
the make script throws an error that it cannot find libexpat.la in
/usr/local/lib although the libexpat.la exists in my apr-util
installation. I have looked everywhere in the Subversion source tree but
I cannot find any reference to the rogue /usr/local/lib/libexpat.la
reference. I have recompiled apache after the expat uninstall so
normally the apache doesn't know there ever was other expat present in
the system.

I am really getting desperate at this point.

Other things I have tried :
- Using Subversion 1.4.2

As you can see from the log below the error occurs when executing
libtool on libsvn_ra_dav-1.la in subversion/libsvn_ra_dav:

cd subversion/libsvn_ra_dav && /bin/bash
/export/home/moudrm1/subversion-1.4.3/libtool --tag=CC --silent
--mode=link gcc -g -O2 -g -O2 -D_LARGEFILE64_SOURCE -DNE_LFS
-L/usr2/local/apr-util/lib -rpath /usr2/local/svn/lib -o
libsvn_ra_dav-1.la commit.lo fetch.lo file_revs.lo log.lo merge.lo
options.lo props.lo replay.lo session.lo util.lo
../../subversion/libsvn_delta/libsvn_delta-1.la
../../subversion/libsvn_subr/libsvn_subr-1.la
/usr2/local/apr-util/lib/libaprutil-1.la -lldap -ldl -lpthread -lexpat
-liconv /usr2/local/apr/lib/libapr-1.la -luuid -lsendfile -lrt -lsocket
-lnsl -lpthread /usr/local/lib/libneon.la -lsocket -lz
libtool: link: warning:
`/usr/local/lib/gcc/sparc-sun-solaris2.10/3.4.6/../../..//libiconv.la'
seems to be moved
libtool: link: warning:
`/usr/local/lib/gcc/sparc-sun-solaris2.10/3.4.6/../../..//libiconv.la'
seems to be moved
grep: can't open /usr/local/lib/libexpat.la
Can't open /usr/local/lib/libexpat.la
libtool: link: `/usr/local/lib/libexpat.la' is not a valid libtool
archive
*** Error code 1
make: Fatal error: Command failed for target
`subversion/libsvn_ra_dav/libsvn_ra_dav-1.la'

-----Original Message-----
From: Moudry, Mipam [mailto:mipam.moudry@medtronic.com]
Sent: mercredi, 4. avril 2007 17:03
To: users@subversion.tigris.org
Subject: Subversion Compilation Problem on Solaris 10 With Apache 2.2.4

Hello,
I have encountered a serious problem with the latest version of
Subversion (1.4.3). I am trying to compile it on my Solaris 10 (sparc)
box agaist Apache 2.2.4. The apache was built from source.

My configure command for subversion : ./configure
--prefix=/usr2/local/svn --with-apxs=/usr/local/apache2/bin/apxs
--with-apr=/usr/local/apache2 --with-apr-util=/usr/local/apache2/

My configure command for apache : ./configure --enable-dav
--enable-dav-fs --enable-dav-lock --enable-deflate --enable-proxy
--enable-ldap --enable-authnz-ldap --enable-proxy-ajp
--enable-proxy-connect --enable-proxy-http --enable-so --enable-ssl
--with-ssl=/usr/local/ssl --with-ldap --with-included-apr

Here are the last output lines of the 'make install' command :
cd subversion/svn && /bin/bash
/usr2/local/temp_apps_mipam/subversion-1.4.3/libtool --tag=CC --silent
--mode=link gcc -g -O2 -g -O2 -D_LARGEFILE64_SOURCE -DNE_LFS
-L/usr/local/apache2/lib -rpath /usr/local/lib -o svn add-cmd.o
blame-cmd.o cat-cmd.o checkout-cmd.o cleanup-cmd.o commit-cmd.o
copy-cmd.o delete-cmd.o diff-cmd.o export-cmd.o help-cmd.o import-cmd.o
info-cmd.o list-cmd.o lock-cmd.o log-cmd.o main.o merge-cmd.o
mkdir-cmd.o move-cmd.o notify.o propdel-cmd.o propedit-cmd.o
propget-cmd.o proplist-cmd.o props.o propset-cmd.o resolved-cmd.o
revert-cmd.o status-cmd.o status.o switch-cmd.o unlock-cmd.o
update-cmd.o util.o ../../subversion/libsvn_client/libsvn_client-1.la
../../subversion/libsvn_wc/libsvn_wc-1.la
../../subversion/libsvn_ra/libsvn_ra-1.la
../../subversion/libsvn_delta/libsvn_delta-1.la
../../subversion/libsvn_diff/libsvn_diff-1.la
../../subversion/libsvn_subr/libsvn_subr-1.la
/usr/local/apache2/lib/libaprutil-1.la -lldap -ldl -lpthread -lexpat
-liconv /usr/local/apache2/lib/libapr-1.la -luuid -lsendfile -lrt
-lsocket -lnsl - lpthread /usr/local/lib/libneon.la -lsocket -lz
ld: warning: file ../../subversion/libsvn_wc/.libs/libsvn_wc-1: linked
to
/usr2/local/temp_apps_mipam/subversion-1.4.3/subversion/libsvn_wc/.libs/
libsvn_wc- 1: attempted multiple inclusion of file
ld: warning: file ../../subversion/libsvn_ra/.libs/libsvn_ra-1: linked
to
/usr2/local/temp_apps_mipam/subversion-1.4.3/subversion/libsvn_ra/.libs/
libsvn_ra- 1: attempted multiple inclusion of file
ld: warning: file ../../subversion/libsvn_delta/.libs/libsvn_delta-1:
linked to /usr2/local/temp_apps_mipam/subversion-
1.4.3/subversion/libsvn_delta/.libs/libsvn_delta-1: attempted multiple
inclusion of file
ld: warning: file ../../subversion/libsvn_diff/.libs/libsvn_diff-1:
linked to /usr2/local/temp_apps_mipam/subversion-
1.4.3/subversion/libsvn_diff/.libs/libsvn_diff-1: attempted multiple
inclusion of file
ld: warning: file ../../subversion/libsvn_subr/.libs/libsvn_subr-1:
linked to /usr2/local/temp_apps_mipam/subversion-
1.4.3/subversion/libsvn_subr/.libs/libsvn_subr-1: attempted multiple
inclusion of file
ld: fatal: recording name conflict: file
`/usr/local/apache2/lib/libexpat.so' and file
`/usr/local/lib/libexpat.so' provide identical dependency names:
libexpat.so.0 (possible multiple inclusion of the same file)
ld: fatal: File processing errors. No output written to .libs/svn
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `subversion/svn/svn'

I have tried pretty much everything I could think of:
        - Uninstalling the solaris expat package: I would get an error
that says that /usr/local/lib/libexpat.so doesn't exist
        - Renaming the apache libexpat.so to something else: I would get
an error that says that /usr/local/apache2/lib/libexpat.so doesn't exist
        - Changing the LD_LIBRARY_PATH to include the apache's
/usr/local/apache2/lib in the first place:no change
        - Changing the LD_LIBRARY_PATH to exclude the /usr/local/lib:no
change
        - Searched the google and subversion sites with all possible
combinations of the error:no solution found

Of course I have rerun the '.configure ' and 'make clean' between each
build attempt. Does anybody know what is happening here?

Thanks,

Mipam Moudry

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Apr 5 14:31:51 2007

This is an archived mail posted to the Subversion Users mailing list.