[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: mod_dav_svn.so not found

From: Ryan Schmidt <subversion-2007a_at_ryandesign.com>
Date: 2007-01-24 06:15:18 CET

On Jan 23, 2007, at 15:51, Goetz, Philip ((NIH/NLM/LHC)) [C] wrote:

> This is on Windows XP.
> I installed Subversion using svn-1.4.2-setup.exe.
> Then I installed Apache 2.2, using apache_2.2.4-win32-x86-no-ssl.msi.
> Then I edited httpd.conf .
> Then I tried starting Apache.
> It gave the error log "Cannot load C:/../modules/mod_dav_svn.so into
> server: The specified module could not be found."
>
> So I uninstalled and reinstalled Subversion, reasoning that the
> Subversion installer might install mod_dav_svn if it could find an
> Apache installation.
>
> But there was still no mod_dav_svn .
>
> Where am I supposed to get this module?

Sort of a tangential answer to your question: the provided Subversion
binaries currently work with Apache 2, but not Apache 2.2. See the
bright yellow warning box on the downloads page. Apache 2.2.3 and
earlier had a problem on Windows where they would not work with
Subversion. Now that 2.2.4 has been released which is supposed to fix
this bug, it is possible that Windows binaries of Subversion built
for Apache 2.2 will be released. But as far as I know, there are none
yet.

-- 
To reply to the mailing list, please use your mailer's Reply To All  
function
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jan 24 06:15:50 2007

This is an archived mail posted to the Subversion Users mailing list.