[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

how come post-commit script not triggered to email commit notifications

From: sqad <sjangity_at_yahoo.com>
Date: 2007-01-05 17:53:10 CET

I am a svn newbie, but I went through many of the threads on svn commit
notifications, but no one had the problem I had - so appreciate the help.

I am following along this guide:
http://wiki.wsmoak.net/cgi-bin/wiki.pl?Subversion/EmailNotification

With the post-commit script, when I run it from command line I get an email
sent, so everything seems to be working AOK:

# ./post-commit /path/to/rep 3

However, when I commit changes to the repository in the Eclipse IDE, using
the SVN plugin, I don't get any email notifications. Doesn't this mean, the
'post-commit' script isn't being triggered?

[contents of script (post-commit)]
------------------------
REPOS="$1"
REV="$2"

/usr/local/scripts/commit-email.pl "$REPOS" "$REV" --from
XXX@yahoogroups.com -s "[SVN-Timely Commit] " me@hotmail.com
--------------------------

I don't understand what the problem is. It works fine via command-line, but
not when I commit the code via eclipse. Help! :-(

-- 
View this message in context: http://www.nabble.com/how-come-post-commit-script-not-triggered-to-email-commit-notifications-tf2926591.html#a8181511
Sent from the Subversion Users mailing list archive at Nabble.com.
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jan 5 17:53:29 2007

This is an archived mail posted to the Subversion Users mailing list.