[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Two things that got me stumped during compilation from source... (but I won in the end!)

From: David Tonhofer <d.tonhofer_at_m-plify.com>
Date: 2006-12-31 22:39:29 CET

Hello,

I have managed to compile "subversion" from the source with not too many
problems (which is nice) but was slowed down somewhat by the problems noted
below. I guess these should be noted/remarked upon more clearly either
in the
output of './configure --help' or in the INSTALL readme file.

1) When installing with the minimal prerequisite packages, i.e. when doing:

          $ tar xzvf subversion-1.x.x.tar.gz
          $ tar xzvf subversion-deps-1.x.x.tar.gz
          $ cd subversion-1.x.x

then one MUST NOT run ./configure with options "|--with-apr"| or
"|--with-apr-util" otherwise mysterious configuration/compilation errors
will occur.

2) When compiling on an x85_64 architecture then (at least when one
   compiles 'neon' along with the rest), one MUST add the
'|--enable-shared'
   option to ./configure (even though this is supposed to be the default) as
   otherwise neon compilation will cause grief:
 
   "|relocation R_X86_64_32 against `a local symbol' can not be used when
    making a shared object; recompile with -fPIC|."
|
   "|--enable-shared" is not needed on 32-bit Intel architecture for
compilation
   to work.

X) Bonus command: What libraries have been used to build 'svn'?

   readelf --dynamic svn

Best regards - and happy new year.

 -- David

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Dec 31 22:38:48 2006

This is an archived mail posted to the Subversion Users mailing list.