[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Issue with LDAP/Apache setup and SVN

From: Thomas Recloux <thomas.recloux_at_gmail.com>
Date: 2006-12-17 14:40:08 CET

> Hi all,

Hi Nathan,

> The question I have is, where does this problem lay? I've had a search
> around on terms I can think of and came up with nothing. Is it a bug? Is
> it just not designed to do this? Should it be implemented a different way?
> Any help would be most appreciated.

I've got exactly the same issue. I noticed that a full chechout was
requesting these urls :

"PROPFIND /svn HTTP/1.1" 401 401
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 391
"PROPFIND /svn/!svn/bln/3051 HTTP/1.1" 207 448
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 391
"PROPFIND /svn/!svn/bln/3051 HTTP/1.1" 207 448
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 391
"PROPFIND /svn/!svn/bln/3051 HTTP/1.1" 207 448
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 448
"PROPFIND /svn/!svn/bc/3051 HTTP/1.1" 207 650
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn HTTP/1.1" 401 401
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 391
"PROPFIND /svn/!svn/bln/3051 HTTP/1.1" 207 448
"PROPFIND /svn HTTP/1.1" 207 637
"PROPFIND /svn/!svn/vcc/default HTTP/1.1" 207 391
"PROPFIND /svn/!svn/bln/3051 HTTP/1.1" 207 448
"PROPFIND /svn HTTP/1.1" 207 637
"REPORT /svn/!svn/vcc/default HTTP/1.1" 200 2635591

/svn is the root of my repository.

Checkouting the hidden subfolder requests these urls :

"PROPFIND /svn/hidden HTTP/1.1" 401 401
"PROPFIND /svn/hidden HTTP/1.1" 401 401

So apache can't check authorizations ont the hidden folder because the
protected path is not requested.

The svnbook says "...the mod_dav_svn module is still asking Apache
httpd to run authorization checks on every path". This seems that in
our case, the check is not asked or that the response is not the one
expected.

I'm running subversion 1.4.2 via apache 2.2.3, on a debian etch box.

-- 
Thomas Recloux
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Dec 17 14:40:45 2006

This is an archived mail posted to the Subversion Users mailing list.