[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Official Stance on KeepAlive

From: Mattheis, Erik W. <Erik.W.Mattheis_at_espn.com>
Date: 2006-12-14 17:57:41 CET

Hmmm. That's not very reassuring, but I'm fairly comfortable since it was working for several months without trouble. Is there an official stance on what KeepAlive should be set to in Apache for mod_svn users?
________________________________________

        Erik Mattheis
        Associate Architect
        Web Development
        ESPN, Inc.

-----Original Message-----
From: Stefan [mailto:algroth@gmx.de]

Hi Erik,

Subversion seems to be quite sensitive about Apaches KeepAlive-directive. I found some issues, which are caused by an 'KeepAlive On'.
So perhaps you solved one problem by getting two others...
Here are the links:
<http://svn.haxx.se/users/archive-2006-08/1052.shtml>
<http://svn.haxx.se/users/archive-2006-09/1008.shtml>

-----Ursprüngliche Nachricht-----
Von: Mattheis, Erik W. [mailto:Erik.W.Mattheis@espn.com]
Gesendet: Mittwoch, 13. Dezember 2006 20:22
An: users@subversion.tigris.org
Betreff: RE: Sudden Problems Creating Directories

I was thinking that the weirdest part was that up until a few days ago, we
had absolutely no problems doing the exact same thing. So, I started digging
into what could have possibly changed since then, and it turns out the
'KeepAlive' directive in Apache's config was switched to 'On' from 'Off'
globally. I added 'KeepAlive Off' to the virtual host for Subversion, and
everything is working once again. Sorry for the wild goose chase! Thanks for
taking the time to respond.
________________________________________

        Erik Mattheis
        Associate Architect
        Web Development
        ESPN, Inc.

From: Mark Phippard [mailto:markphip@gmail.com]

Weird. I was also expecting to see the same error about creating the
directory.

Try running svn log against the repos root and see what it says about those
revisions. Maybe somehow the space in the name is causing the folder to be
created in a different location?

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Dec 14 17:58:41 2006

This is an archived mail posted to the Subversion Users mailing list.