[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: apr version problem with subversion 1.42

From: Kris Deugau <kdeugau_at_vianet.ca>
Date: 2006-12-07 17:04:06 CET

warren.l.dodge@exgate.tek.com wrote:
> Hi, I have a question about subversion-1.42
>
> I am using gnu-Linux and have the apr package version 0.9.4 which
> doesn't match the needs for subversion
>
> checking APR version... 0.9.4
> wanted regexes are 0\.9\.[7-9] 0\.9\.1[0-9] 1\.
> configure: error: invalid apr version found
>
> Do you know if 0.9.4 is "ok" or not? We are at the mercy of Redhat in
> updating this so it is unlikely to happen anytime soon.

This sounds like RHEL3 or RHEL4. FWIW, I've been using Subversion on
both, compiled against the native 0.9.4 APR version, without trouble for
a while now.

I haven't stressed Subversion very hard, but I've used just about every
capability at least once.

Replacing APR on RHEL is something of a major headache, because it isn't
packaged separately; it's part of the Apache2 (httpd) package. There
are a LONG list of patches for this package; I suspect that whatever
made the upstream APR unsuitable at that particular version isn't a factor.

-kgd

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Dec 7 17:05:23 2006

This is an archived mail posted to the Subversion Users mailing list.