[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Errors compiling SVN 1.4.0 on Solaris 9

From: Watson, Chris <cwatson_at_ptc.com>
Date: 2006-10-18 10:29:04 CEST

There have been previous threads on this in the developer mailing list - I suggest you have a search on there for more details.
 
What I found is that it needs to be the gnu linker that gets used - my gcc was set up to use /usr/ccs/bin/ld; and I had to rename it to get the gnu linker picked up and the link to work.

________________________________

From: Ed Hillmann [mailto:edhillmann@yahoo.com]
Sent: Wed 18-Oct-06 6:00 AM
To: SubversionUsersMailingList
Subject: Errors compiling SVN 1.4.0 on Solaris 9

I seem to be unable to compile SVN 1.4.0 on my Solaris 9 box. I have been able to compile SVN 1.3 in the past, but I'm having no luck. I get the same error, whether I'm using GCC 3 or 4. And I'm don't understand the message.

It seems to have compiled everything, but it's falling over trying to link together the ra_dav library. The command that is failing is

cd subversion/libsvn_ra_dav && /bin/ksh /ct/ctapp/subversion-1.4.0/objdir/libtool --tag=CC --silent --mode=link gcc -g -O2 -g -O2 -pthread -D_LARGEFILE64_SOURCE -DNE_LFS -L/ct/ctapp/gnu/gcc/product/4.1.1/lib -R/ct/ctapp/gnu/gcc/product/4.1.1/lib -L/ct/ctapp/subversion-1.4.0/objdir/apr-util/xml/expat/lib -rpath /u01/ct/ctapp/svn-1.4.0/lib -o libsvn_ra_dav-1.la commit.lo fetch.lo file_revs.lo log.lo merge.lo options.lo props.lo replay.lo session.lo util.lo ../../subversion/libsvn_delta/libsvn_delta-1.la ../../subversion/libsvn_subr/libsvn_subr-1.la /ct/ctapp/subversion-1.4.0/objdir/apr-util/libaprutil-0.la /ct/ctapp/subversion-1.4.0/objdir/apr-util/xml/expat/lib/libexpat.la /ct/ctapp/subversion-1.4.0/objdir/apr/libapr-0.la -lsendfile -lrt -lm -lsocket -lnsl -lresolv -lpthread -ldl /ct/ctapp/subversion-1.4.0/objdir/neon/src/libneon.la -lsocket -lz

I get a whole stack of errors (over 2300 lines) like the following

Text relocation remains referenced
    against symbol offset in file
<unknown> 0x510 /ct/ctapp/subversion-1.4.0/objdir/neon/src/.libs/libneon.a(ne_request.o)
<unknown> 0x514 /ct/ctapp/subversion-1.4.0/objdir/neon/src/.libs/libneon.a(ne_request.o)
<unknown> 0x518 /ct/ctapp/subversion-1.4.0/objdir/neon/src/.libs/libneon.a(ne_request.o)
<unknown> 0x51c /ct/ctapp/subversion-1.4.0/objdir/neon/src/.libs/libneon.a(ne_request.o)
<unknown> 0x520 /ct/ctapp/subversion-1.4.0/objdir/neon/src/.libs/libneon.a(ne_request.o)
...
ld: fatal: relocations remain against allocatable but non-writable sections
collect2: ld returned 1 exit status

I've found the following link (http://docsun.cites.uiuc.edu/sun_docs/C/solaris_9/SUNWdev/LLM/p24.html) which points to this message. For each one of these lines, the .o file didn't generate position-independant code? It looks like all the lines are from the libneon.a file, so that file hasn't been built properly? Is there a parameter that I should use with the configure to ensure that this file is built correctly?

Er, am I even close on this? Has anyone else seen this?

Thanks for any help,
Ed

       

       
               
____________________________________________________
On Yahoo!7
Messenger: Plug-in the fun with handy plug-ins
http://au.messenger.yahoo.com <http://au.messenger.yahoo.com/>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Oct 18 10:32:16 2006

This is an archived mail posted to the Subversion Users mailing list.