[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Differences in Behaviour between Verion 1.3 and 1.4 of svnserve

From: Thomas Fiebig <thomas.fiebig_at_gcd-solutions.de>
Date: 2006-10-10 09:49:57 CEST

Hello,

we are actually running svnserve Version 1.3 for version control with no
problems.

After announcing Version 1.4 we want to upgrade. Being the cautious one,
we tried a test installation first. And detect differences in behaviour.

We manage not only one but many repositories with svnserve. The root
directory for all repositories is the same, but between this layer and
the layer of the repositories, we have implemented a directory layer to
distribute between different customers with their projects.

This "customer" layer has directory named in some cases something like
"customer A". The name contains a space. So to access a repository of
this customer you have access

        svn://<SVN_MACHINE>/customer A/<REPOSITORY_NAME>

With Version 1.3 no problem occurs at any time with this kind of access.
With Version 1.4 after questioning name and password, svnserve detects
differences between svn://<SVN_MACHINE>/customer A/<REPOSITORY_NAME> and
svn://<SVN_MACHINE>/customer%20A/<REPOSITORY_NAME>.

Is this a bug, a feature, or do I make a mistake?

We start version 1.3 and 1.4 with the same wrapper (I know, not
necessary for Version 1.4).

Any ideas?

Thanks,
Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Oct 10 18:00:27 2006

This is an archived mail posted to the Subversion Users mailing list.