[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Multiple authentication not working

From: Antao Almada <antao_at_iilab.com>
Date: 2006-09-29 17:19:36 CEST

Could someone help on this one? I've been having the exact same
problem... :-[

Giacecco wrote:
> I am setting up a new 1.4 Svn server. This time, I want to get both Windows
> authentication and basic authentication running, following the instructions
> at
> http://tortoisesvn.net/docs/release/TortoiseSVN_en/tsvn-serversetup.html#tsvn-serversetup-apache-6
> . I am using the binary Subversion distribution, Apache 2.0.59 (no SSL yet)
> and mod_auth_sspi 1.0.4 .
>
> The instructions are very good, but I think they may be wrong in describing
> the multiple authentication settings. There is also an explicit mistypo
> where it says that both AuthAuthoritative and SSPIAuthoritative must be set
> to Off, and then SSPIAuthoritative is On a few lines later in the example.
>
> What happens is that - in visiting the page with Firefox (so not to be
> automatically recognised as it would happen with IE) - the first
> authentication request dialog I get is the basic authentication one; I
> insert a correct username/password couple, then get a new authentication
> request dialog, this time for the Windows authentication.
>
> I am sure I am not far from the solution because - if I comment one or the
> other set of settings - the remaining authentication works fine. Here is my
> Apache Location directive:
>
> <Location />
> DAV svn
> SVNListParentPath on
> SVNParentPath "c:/svn_NEW"
> AuthName "Subversion Authentication"
>
> # NT Domain authentication
> AuthType SSPI
> SSPIAuth On
> SSPIAuthoritative Off
> SSPIDomain BULLDOG
> SSPIOfferBasic On
>
> # htpasswd authentication
> AuthType Basic
> AuthAuthoritative Off
> AuthUserFile "c:/svn_NEW/passwd"
>
> # path-based authorization
> AuthzSVNAccessFile "c:/svn_NEW/authz"
> Require valid-user
> </Location>
>
> Any advice? Thank you in advance,
>
> Giacecco
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Sep 29 17:20:30 2006

This is an archived mail posted to the Subversion Users mailing list.