[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

pre-revprop-change Hook with WebDAV

From: Stephen Bash <scbash_at_gmail.com>
Date: 2006-09-28 22:30:48 CEST

Hi everyone! I'm new to the Subversion mailing lists, but I've been
using svn for several years now and I've been very happy.

On to the question. Recently I helped our repository administrator
set up a pre-revprop-change hook script. I tested it on my system
(Gentoo Linux with Subversion 1.3.2) using svnserve and had no
troubles. When our admin installed it on the server (Fedora, but I
don't know either the system version or Subversion version) using
WebDAV we ran into the problem where DAV doesn't send error messages
back to the user. I recently recreated the behavior on my Gentoo box
using WebDAV and Subversion 1.3.2.

This is apparently a common problem as I found issue 443 and several
threads on the user and dev lists talking about various aspects of it.
 So I'm curious if someone knows the current status of hook scripts
(specifically pre-revprop-change) and error messages over DAV (either
in 1.4 or current development)? Has the problem been fixed or is
there a current issue I can watch to follow progress? (It looked like
443 was targeted specifically at the pre- and post-commit scripts)

Thanks!

Stephen

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Sep 28 22:31:22 2006

This is an archived mail posted to the Subversion Users mailing list.