[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 301 Moved Permanently ( Apologies )

From: Duncan Murdoch <murdoch_at_stats.uwo.ca>
Date: 2006-09-17 20:14:11 CEST

On 9/17/2006 12:43 PM, Matt Duffy wrote:
> To be totally honest, NO, that FAQ didn't help me, and I don't think it helps a vast majority of people who encounter the 301 error, or else there wouldn't be so many people continually posted new threads asking about it. I am not trying to be rude or anything, but that FAQ seems, to me at least, to cover a very specific issue. And that is not the issue I was having. I did not have any weird overlap in my DocumentRoot vs <Location> filesystem paths. My issue seems to stem entirely from the fact that Subversion (at least 1.3.1 installed with Apache 2.0.x) doesn't handle a <Location /> directive gracefully.
>
> I fixed my problem by simply adding the line:
>
> Alias / /path/to/repoitory/parent
> <Location />
> ###
> </Location>
>
> Now, I readily admit I am no expert with either Apache or Subversion, but adding that Alias line fixed my problem and I don't see how its related in any way to what http://subversion.tigris.org/faq.html#http-301-error is specifically addressing. Believe me, I wouldn't have created yet another new 301 thread if I felt the FAQ addressed my problem.

Why not submit a patch to the FAQ?

Duncan Murdoch
>
> Cheers,
> Matt
>
>
>
> -----Original Message-----
> From: Erik Huelsmann [mailto:ehuels@gmail.com]
> Sent: Sat 9/16/2006 12:09 AM
> To: Matt Duffy
> Cc: users@subversion.tigris.org
> Subject: Re: 301 Moved Permanently ( Apologies )
>
> This FAQ issue doesn't help:
> http://subversion.tigris.org/faq.html#http-301-error ?
>
> bye,
>
> Erik.
>
> On 9/16/06, Matt Duffy <Matt_Duffy@kessler.com> wrote:
>> Ack!
>>
>> My apologies for so many duplicates of me emails going through. I attribute that to an unfortunate combination of a flakey Exchange server, too much coffee and the fact that its Friday.
>>
>> My issue with the 301 error was resolved as I mentioned in my earlier posting by using 'Alias / /path/to/svn/parent_dir' just before the <location> tag. I hope that helps others who are experiencing the 301 error.
>>
>> Cheers,
>> Matt
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
>> For additional commands, e-mail: users-help@subversion.tigris.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Sep 17 20:14:57 2006

This is an archived mail posted to the Subversion Users mailing list.