[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: First experiences: svn: This client is too old

From: Mark Clements <gmane_at_kennel17.co.uk>
Date: 2006-09-14 15:21:58 CEST

"Jeremy Pereira" <jeremyp@jeremyp.net> wrote in message
news:BD1C592A-35D1-43B1-84B8-89535F2784CB@jeremyp.net...
> Slightly off topic:
>
> On 13 Sep 2006, at 19:24, Andy Levy wrote:
>
> >
> > "Using TortoiseSVN 1.4.0-rc1 on any working copy created by previous
> > versions of Subversion/TSVN will TRANSPARENTLY upgrade your working
> > copy, which means that production-ready versions of Subversion/TSVN
> > (1.3.x and earlier) will no longer be able to read it!
>
> Being pedantic, the correct word is "SILENTLY". "TRANSPARENTLY"
> implies you don't need to worry about it, but in fact what happens is
> completely the opposite of transparent.
>
> > Please be...
> >

Is there are reason that it does not give a suitable warning that it is
about to do something that could turn out to be a very Bad Thing? A simple
confirmation prompt would, or a separate 'update-wc' command would surely
save everyone a lot of headaches...

- Mark Clements (HappyDog)

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Sep 14 15:23:07 2006

This is an archived mail posted to the Subversion Users mailing list.