[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion 1.4.0 released.

From: Lorenz <lorenznl_at_yahoo.com>
Date: 2006-09-12 09:40:03 CEST

David Anderson wrote:
>* Sean Kelley <sean.sweng@gmail.com> [2006-09-12 00:07:22]:
>> > * Due to various improvements made to the working copy library, the
>> > working copy format has changed. Using Subversion 1.4.0 on any
>> > working copy created by previous versions of Subversion will
>> > SILENTLY upgrade your working copy, which means that previous
>> > versions of Subversion will no longer be able to read it.
>>
>> Does this change imply that if you are using a third party client like
>> SmartSVN, you need to wait on updating the server until all clients,
>> such as SmartSVN, have been updated to support SVN 1.4?
>
>No. Any 1.X client will continue to work with any 1.Y server (though
>features may be lost, obviously). It means that when SmartSVN starts
>using 1.4 libraries, your working copies will be unreadable by
>previous versions of SmartSVN.

But it also means, that you can _not_ mix a pre 1.4 SmartSVN with a
1.4 svn commandline client, as the later will update your working
copy.

Lorenz

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Sep 12 09:41:40 2006

This is an archived mail posted to the Subversion Users mailing list.