[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn 1.4 and apache 2.2.3

From: Garrett Rooney <rooneg_at_electricjellyfish.net>
Date: 2006-09-11 23:52:43 CEST

On 9/11/06, Steve Baker <Steve.Baker@hj3m.com> wrote:
> Hi all,
>
> I read a post in this list back in august that svn 1.3 would work with
> apache 2.2.3 but would require a custom build. I read somewhere also
> around that time that svn 1.4 was expected to have apache 2.2.3 support.
>
>
> I am having problems finding any docs for svn 1.4 that mention which
> version of apache is supported out of the box. I am setting up a new svn
> 1.4 server at work and just need to know which version of apache to
> install. I don't really know much about apache and have no idea if I
> would benefit from the 2.2.3 release. I do know that I will be trying to
> set up active directory authentication with mod_auth_sspi.
>
> Would someone be willing to help me out and just let me know if I should
> be using 2.0.59 or 2.2.3 please? I would be willing to build svn against
> 2.2.3 if there is some advantage to doing that in general or when using
> sspi. Otherwise I would prefer to just stick with downloading binaries.

1.4 works just fine with apache 2.2, as long as you're not on windows.
 If you're on windows it needs a patch to APR 1.x (which is what
apache 2.2 uses) in order to fix a bug that we happen to trip up, so
you'll have to either patch your version of APR or use apache 2.0.

-garrett

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Sep 11 23:53:49 2006

This is an archived mail posted to the Subversion Users mailing list.