[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: impossible to import single files

From: Ryan Schmidt <subversion-2006c_at_ryandesign.com>
Date: 2006-09-05 12:31:28 CEST

Please use the Reply To All feature of your email program when
replying so that your replies go to the mailing list also, not just
to me.

On Sep 5, 2006, at 12:24, Bernd BŁttner wrote:

>> Please show us the exact Subversion commands which fail to do what
>> you want and the resultant error messages. (It's hard to guess.)
>> If you're saying that you can't import directly into http://
>> svn.intern.mko-gmbh.de/ (directly into e:\svn) then that's
>> expected; you need to specify the name of the repository into
>> which you want to import. http://svn.intern.mko-gmbh.de/<reponame>/
>> <whatever>. You need to have created that repo with "svnadmin
>> create e:\svn\<reponame>" first. If you don't want to have to
>> create new repositories all the time, consider using a single
>> repository to store everything. Then you'd use SVNPath in the
>> Apache configuration, not SVNParentPath.
>
> Sorry, I was not exact enough.
> On the server I created a directory named e:\svn\test.
> Into that directory created a repository with TortoiseSVN.
> On the client created somewhere a temp directory with 3 empty
> subdirectories (trunk,branches,tags).
> Imported the temp directory with TortoiseSVN into the repository
> test, which worked successful.
> Now I had an repository with 3 empty directories.
> At least I tried to import an existing (not SVN based) project with
> files and subdirectories to the repository test/trunk (again with
> TortoiseSVN).
> This operation failed:
>
> Apache error log:
> [Tue Sep 05 12:17:43 2006] [error] [client 172.16.0.10] (20014)
> Error string not specified yet: Can't open file 'e:\\svn\\error\
> \format': Das System kann den angegebenen Pfad nicht finden.
> [Tue Sep 05 12:17:43 2006] [error] [client 172.16.0.10] Could not
> fetch resource information. [500, #0]
> [Tue Sep 05 12:17:43 2006] [error] [client 172.16.0.10] Could not
> open the requested SVN filesystem [500, #720003]
> [Tue Sep 05 12:17:43 2006] [error] [client 172.16.0.10] Could not
> open the requested SVN filesystem [500, #720003]

Ok, you have a repository "test". But the error message above shows
that you're trying to access a repository called "error" and that it
can't find one.

Can you try your import using the svn command line instead of
TortoiseSVN, and if you still get the same error, then showing us
what command you issued?

> SVN access log:
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/trunk
> HTTP/1.1" 207 678 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/!svn/
> vcc/default HTTP/1.1" 207 390 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/!svn/
> bln/1 HTTP/1.1" 207 441 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/!svn/
> bc/1/trunk HTTP/1.1" 207 688 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "OPTIONS /test/trunk
> HTTP/1.1" 200 184 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "MKACTIVITY /test/!svn/
> act/8dcad4bb-2c25-4443-95c6-e6914334143e HTTP/1.1" 201 368 "-" "SVN/
> 1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/trunk
> HTTP/1.1" 207 430 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/!svn/
> vcc/default HTTP/1.1" 207 390 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "CHECKOUT /test/!svn/
> bln/1 HTTP/1.1" 201 382 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPPATCH /test/!svn/
> wbl/8dcad4bb-2c25-4443-95c6-e6914334143e/1 HTTP/1.1" 207 349 "-"
> "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/trunk
> HTTP/1.1" 207 386 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "CHECKOUT /test/!svn/
> ver/1/trunk HTTP/1.1" 201 386 "-" "SVN/1.3.2 (r19776) neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "PROPFIND /test/trunk/
> wnd_delete_php_error.php HTTP/1.1" 500 239 "-" "SVN/1.3.2 (r19776)
> neon/0.25.4"
> 172.16.0.10 - - [05/Sep/2006:12:17:43 +0200] "DELETE /test/!svn/act/
> 8dcad4bb-2c25-4443-95c6-e6914334143e HTTP/1.1" 204 - "-" "SVN/1.3.2
> (r19776) neon/0.25.4"
>
> The SVNParentPath configuration is exactly what I want to use.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Sep 5 12:32:58 2006

This is an archived mail posted to the Subversion Users mailing list.