[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svn client lag

From: Stromek <stromek_at_realtime.sk>
Date: 2006-09-04 17:07:31 CEST

Hi folks,

I'm here with another question bothering my life with svn :)

The best way to demonstrate the problem is to use tortoise svn client
(see next paragraph for explaining with regular svn client).
Suppose you want to browse a repository with url svn://svn/proj1. You
click the directory and it starts to do pretty long lags >10sec-1min.
Sometimes it starts after second click, sometimes after fifth click.
Under this condition, svn is pretty unsuable.

If we look at the problem from the side of regular svn client it looks
like this. Take
for example that checkout of proj1 populates some directories from
another repository, say svn://svn/proj2. Each new request to external
repository take pretty much time to start (>10sec-1min).

Just to make it clear, directories contain just several files
(10-20).

Has someone encountered similar problem before? Or has any idea what should
I try or how should I force svnserve to give some useful information
about its processing? Thanks.

-- 
Stromek
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Sep 4 17:08:55 2006

This is an archived mail posted to the Subversion Users mailing list.