[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: propedit on repository with spaces in URL

From: Ryan Schmidt <subversion-2006c_at_ryandesign.com>
Date: 2006-09-01 00:24:36 CEST

On Aug 31, 2006, at 17:05, ESSI - Billie H. Cleek wrote:

> No one has responded in some time. I have confirmed that this is a
> problem with both the Windows client and the Linux client. I have
> searched the issue tracker and come up empty. Is it time to file a
> bug?

I had certainly forgotten about the problem, though I saved the
previous messages in the thread because it sounded interesting. I
just confirmed the behavior on Mac OS X 10.4.7 PPC with Subversion
1.3.2 and it sure looks buggy to me. I note that although you said
you only had problems with propedit and not with propset, I observe
the problem with propset. A reproduction script is attached (which
you must read and configure before running). Here is its output on my
system:

$ ./spaces_in_url.sh
--> Making repository 'foobarrepo14496'
--> Adding pre-revprop-change hook script
--> Checking out working copy
Checked out revision 0.
--> Adding a revision to the repository
A foobarwc14496/foo
Adding foobarwc14496/foo
Transmitting file data .
Committed revision 1.
--> Removing working copy
--> Changing the log message
property 'svn:log' set on repository revision 1
--> Renaming repository 'foobarrepo14496' to 'foobar repo14496'
--> Changing the log message
svn: DAV request failed; it's possible that the repository's pre-
revprop-change hook either failed or is non-existent
svn: At least one property change failed; repository is unchanged
--> Removing repository 'foobar repo14496'

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

Received on Fri Sep 1 00:29:02 2006

This is an archived mail posted to the Subversion Users mailing list.