[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Fwd: Re: Apache2 - Subversion configuration

From: Keith Rogers <keith.rogers_at_mouchelparkman.com>
Date: 2006-07-03 17:45:17 CEST

I had changed the repository path, but kept refering to the folder as "project" in these emails

I am convinced that the problem is with the novell apparmor running on the server - I have tried modifying the profile to give the apache process read/write access to the repository folder, but with no success.

Does anyone here have any experience with apparmor?

Thanks

Keith

(thanks Ryan!)

>>> Ryan Schmidt <subversion-2006c@ryandesign.com> 03/07/2006 15:18:31 >>>
On Jul 3, 2006, at 16:01, Keith Rogers wrote:

>>> The logs do contain some interesting info!
>>>
>>> According to the apache log, the problem is that it can't access
>>> the /srv/svn/repos/project/format file. I changed the permissions
>>> on this file to allow everyone read/write access, but the message
>>> is still appearing in the logs..
>>
>> That all sounds reasonable... why isn't it working? Hmm... Are all
>> the directories leading up to that file (/srv, /srv/svn, /srv/svn/
>> repos, etc.) readable and executable by Apache?
>
> Yes, every directory up to that file is readable/executable by all.
> Here is the error message from the apache2 log:
>
> [Wed Jun 28 20:39:51 2006] [error] [client 172.17.2.56] (20014)
> Error string not specified yet: Can't open file '/usr/share/svn/ims/
> format': Permission denied
> [Wed Jun 28 20:39:51 2006] [error] [client 172.17.2.56] Could not
> fetch resource information. [500, #0]
> [Wed Jun 28 20:39:51 2006] [error] [client 172.17.2.56] Could not
> open the requested SVN filesystem [500, #13]
> [Wed Jun 28 20:39:51 2006] [error] [client 172.17.2.56] Could not
> open the requested SVN filesystem [500, #13]
>
> (excuse the wildly incorrect date/time - this is running on a
> virtual machine)

Perhaps this is a stupid question :-) but I have no experience with
virtual machines... The Apache configuration points at /srv/svn/repos/
project which is where you actually have the repository. But the
Apache error log says it cannot find /usr/share/svn/ims? How do we
reconcile that discrepancy?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

The information in this e-mail is confidential and intended to be solely for the use of the addressee(s) and may contain copyright and/or legally privileged information. If you are not the addressee (or responsible for delivery of the message to the addressee) please e-mail us at Postmaster@mouchelparkman.com and delete the message from your computer; copying, distribution, use or disclosure of its contents is strictly prohibited.
As Internet communications are capable of data corruption no responsibility is accepted for changes made to this message after it was sent. For this reason it may be inappropriate to rely on advice contained in any e-mail without obtaining written confirmation of it.
In addition, no liability or responsibility is accepted for viruses and it is your responsibility to scan attachments (if any).
Please note that for business purposes, outgoing and incoming emails from and to the company may be monitored and recorded.

Mouchel Parkman Services Ltd, Registered in England at West Hall, Parvis Road, West Byfleet, Surrey UK KT14 6EZ Registered No : 1686040

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Jul 3 17:46:31 2006

This is an archived mail posted to the Subversion Users mailing list.