[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: mod_authz_svn error in latest svn 13x build: 'SATISFY_ANY' undeclared (first use in this function)

From: Max Bowsher <maxb1_at_ukf.net>
Date: 2006-03-07 13:20:42 CET

Hash: SHA1

OpenMacNews wrote:
> hi all,
> building
> svn co http://svn.collab.net/repos/svn/branches/1.3.x/
> r18733
> against apache-dev (httpd-trunk, apr & apr-util (Revision: 383442)):
> /usr/ports/subversion13x/subversion/mod_authz_svn/mod_authz_svn.c:374:
> error: 'SATISFY_ANY' undeclared (first use in this function)
> i'm *guessing* this has to do with recent changes in Apache trunk:
> % /usr/ports/httpd-dev/httpd-trunk > grep Authz CHANGES
> *) Authz: Add the new module mod_authn_core that will provide common
> *) Authz: Mark the directives 'Order', 'Allow', 'Deny' and 'Satisfy' as
> *) Authz: Move the 'Require' directive from the core module as well as
> *) Authz: Add the new module mod_authz_core which acts as the
> *) Authz: Renamed mod_authz_dbm authz providers from 'group' and
> *) Authz: Added the new authz providers 'env', 'ip', 'host', 'all' to
> handle
> *) Authz: Convert all of the authz modules from hook based to
> but unclear :-|
> is there an issue with *authz* that'll force me to a newer svn branch
> for apache-dev compatibility? i'm poring over prereqs/lists/etc ...
> haven't found 'wisdom' yet.

If you are using apr, apr-util and httpd trunk, does it not make sense
to investigate svn trunk too?

Version: GnuPG v1.4.1 (Cygwin)


To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Mar 7 13:22:25 2006

This is an archived mail posted to the Subversion Users mailing list.