[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Linker error on intall with libsvn_client

From: Himanshu Gohel <gohel_at_cse.usf.edu>
Date: 2005-09-19 13:49:25 CEST

[SGI IRIX 6.5.20m, gcc 3.3, ld is SGI IRIX native]

Since my original message a few days ago I've been trying various configure
options to get subversion to build/install, but this seems to be the
stumbling block:

<...>
ld32: WARNING 85: definition of __deregister_frame_info in
/usr/people/gohel/dow
nloads/subversion-1.2.3/apr-util/.libs/libaprutil-0.so preempts that
definition
in
/usr/people/gohel/downloads/subversion-1.2.3/apr-util/xml/expat/lib/.libs/li
b
expat.so.
ld32: Giving up after printing 50 warnings. Use -wall to print all
warnings.
ld32: Segmentation fault. Removing output file...
collect2: ld returned 1 exit status
libtool: install: error: relink `libsvn_client-1.la' with the above command
befo
re installing it
gmake: *** [install-lib] Error 1

I don't think the seg fault is due to the warnings about pre-emptive
definitions. Almost all the libs before this one give the same warnings,
but I find those lib*.so.* files in the build tree when I run a find.
However, I cannot find libsvn_client-1.so.1. So I ran the link command
manually as the error suggests:

libtool: install: warning: relinking `libsvn_client-1.la'
(cd /usr/people/gohel/downloads/subversion-1.2.3/subversion/libsvn_client;
/bin/sh /usr/people/gohel/downloads/subversion-1.2.3/libtool --tag=CC
--silent --mode=relink /usr/freeware/bin/gcc -g -O2 -g -O2 -DNEON_ZLIB
-L/usr/people/gohel/downloads/subversion-1.2.3/apr-util/xml/expat/lib -rpath
/usr/local/lib -o libsvn_client-1.la add.lo blame.lo cat.lo checkout.lo
cleanup.lo commit.lo commit_util.lo copy.lo ctx.lo delete.lo diff.lo
export.lo externals.lo info.lo locking_commands.lo log.lo ls.lo
prop_commands.lo ra.lo relocate.lo repos_diff.lo resolved.lo revert.lo
revisions.lo simple_providers.lo ssl_client_cert_providers.lo
ssl_client_cert_pw_providers.lo ssl_server_trust_providers.lo status.lo
switch.lo update.lo url.lo username_providers.lo version.lo
../../subversion/libsvn_wc/libsvn_wc-1.la
../../subversion/libsvn_ra/libsvn_ra-1.la
../../subversion/libsvn_delta/libsvn_delta-1.la
../../subversion/libsvn_diff/libsvn_diff-1.la
../../subversion/libsvn_subr/libsvn_subr-1.la
/usr/people/gohel/downloads/subversion-1.2.3/apr-util/libaprutil-0.la
/usr/people/gohel/downloads/subversion-1.2.3/apr-util/xml/expat/lib/libexpat
.la -liconv /usr/people/gohel/downloads/subversion-1.2.3/apr/libapr-0.la -lm
-lpthread )
libsvn_client-1.so.1.0 - No such file or directory
libtool: install: error: relink `libsvn_client-1.la' with the above command
before installing it
libsvn_client-1.so.1.0 - No such file or directory

Any ideas on how to get this to build/link/install?

Thank you!

--
Himanshu 
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Sep 19 13:51:30 2005

This is an archived mail posted to the Subversion Users mailing list.