[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

subversion svn+ssh and password problems

From: Waldemar Brodkorb <wbx_at_aurisp.de>
Date: 2005-09-07 13:34:02 CEST

Hi,

I like to use subversion with SSH and password authentication to
access a repository. Unfortunately svn command line client ask two
times for a password and only the second time authentication
succeeds. I use subversion 1.1.4 on Debian or OpenBSD with OpenSSH
and can reproduce the problem. So it is definetely not an OpenSSH or
PAM issue. Next I tried subversion 1.2.3 and the svn client and now
I need to authenticate three times before it succeeds.

The main problem is that I think this is the reason why Eclipse 3.1
with Subclipse 0.9.33 under Windows XP does not work with Secure
Shell and password authentication. I tried both methods, JavaHL and
JavaSVN. The first one works great with public key authentication.

We will now switch over to https, but I would like to discuss if
this is a stupid problem on my side or a bug. I did not find
anything about it in the issue tracker or mailinglist archive.

Thanks for any help.

bye
    Waldemar

-- 
AurISP IT Consulting, Brodkorb & Ehrhardt GbR
E-Mail:   wbx_at_aurisp.de          Homepage: http://www.aurisp.de
Telefon:  +49 163 77 84 945      Telefax: +49 228 37 85 74
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Sep 7 13:35:54 2005

This is an archived mail posted to the Subversion Users mailing list.