[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svn: PROPFIND request failed upon file add --HELP

From: Ernst Johannes <jernst+tigris.org_at_netmesh.us>
Date: 2005-09-01 19:27:50 CEST

I'm at the end of my stick, and Google is of no help. I'm getting the
following error message, every time I try to add a new file or rename
an existing file:

svn: PROPFIND request failed on '/websites/trunk/www.metamodel.com/
INSTALL.txt'

Of course, it can't do a PROPFIND, the file doesn't exist yet! So
what's wrong here?

I doing this, for example:

[jernst]$ svn info INSTALL
Path: INSTALL
Name: INSTALL
URL: <some-url starting with http:// ... edited>
Repository UUID: 34f2091e-d9fd-0310-bbcc-f5f6c5d413fd
Revision: 5
Node Kind: file
Schedule: normal
Last Changed Author: jernst
Last Changed Rev: 3
Last Changed Date: 2005-08-08 13:51:07 -0700 (Mon, 08 Aug 2005)
Text Last Updated: 2005-09-01 09:44:55 -0700 (Thu, 01 Sep 2005)
Properties Last Updated: 2005-09-01 09:44:55 -0700 (Thu, 01 Sep 2005)
Checksum: 3803b5613d4536a4af1c1e95964917c4

[jernst]$ svn mv INSTALL INSTALL.txt
A INSTALL.txt
D INSTALL
[jernst]$ svn commit . -m 'add extension to INSTALL file'
Deleting www.metamodel.com/INSTALL
Adding www.metamodel.com/INSTALL.txt
svn: Commit failed (details follow):
svn: PROPFIND request failed on '/websites/trunk/www.metamodel.com/
INSTALL.txt'
svn: Could not open the requested SVN filesystem

The apache error log says this, at the same time:

[Thu Sep 01 10:05:24 2005] [error] [client 204.145.147.224] (20014)
Error string not specified yet: Can't open file '/data/svn/error/
format': No such file or directory
[Thu Sep 01 10:05:24 2005] [error] [client 204.145.147.224] Could not
fetch resource information. [500, #0]
[Thu Sep 01 10:05:24 2005] [error] [client 204.145.147.224] Could not
open the requested SVN filesystem [500, #2]
[Thu Sep 01 10:05:24 2005] [error] [client 204.145.147.224] Could not
open the requested SVN filesystem [500, #2]

There are some posts of mod_deflate prior to Apache 2.0.48 causing
this, but I'm not running either. Otherwise I'm clueless what those
things might mean -- for example, I don't have a file /data/svn/error/
format. In fact, I have no idea where it got the directory /data/svn/
error from, because I don't have any directory called 'error' anywhere.

My apache config:

     <Location />
         DAV svn
         SVNParentPath /data/svn

         AuthType Basic
         AuthName "SVN Realm"
         AuthUserFile ...edited
         AuthGroupFile ...edited
         Require group ...edited
     </Location>

This is RedHat, Kernel 2.4.21-32.0.1.ELsmp
Apache/2.0.54
svn, version 1.2.3 (r15833), downloaded and compiled fresh last night.
This is a file-based repository, does not use Sleepycat
1.2.1 behaved the same way I believe.

Your help, if any, is very much appreciated.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Sep 1 19:30:34 2005

This is an archived mail posted to the Subversion Users mailing list.