[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Error upgrading to FSFS

From: Jared Parsons <jaredp_at_comcast.net>
Date: 2005-07-17 20:28:09 CEST

I’m running into a problem upgrading my repositories to FSFS.  After
upgrading, I can no longer view my repository in Apache or access it
from the command line.  I ran through the error logs and it appears that
Apache is trying to access my repository as a Berkley DB instead of a
FSFS.  Here is the log entry

Sun Jul 17 11:01:00 2005] [error] [client 192.168.0.101] (20014)Error
string not specified yet: Berkeley DB error while opening 'nodes' table
for filesystem d:\\SvnRepository\\jaredp/db:\nNo such file or directory
[Sun Jul 17 11:01:00 2005] [error] [client 192.168.0.101] Could not
fetch resource information.  [500, #0]
[Sun Jul 17 11:01:00 2005] [error] [client 192.168.0.101] Could not open
the requested SVN filesystem  [500, #160029]
[Sun Jul 17 11:01:00 2005] [error] [client 192.168.0.101] (2)No such
file or directory: Could not open the requested SVN filesystem  [500,
#160029]

Platform Info: Windows XP SP2
Running: Subversion 1.2.0
            Apache 2.0.54

Upgrade Steps
            1) Dump old repository
            2) Uninstall Apache 2.0.52
            3) Uninstall Subversion
            4) Install Apache 2.0.54
            5) Install Subversion 2.0
            6) Create repository
            7) Import repository settings

-- 
Jared Parsons
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Jul 17 20:41:48 2005

This is an archived mail posted to the Subversion Users mailing list.