[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: entries file corruption

From: John Szakmeister <john_at_szakmeister.net>
Date: 2005-07-10 23:04:36 CEST

On Wednesday 06 July 2005 05:50, Florian Schricker wrote:
> Hello everybody,
>
>
> I'm fairly new to this list and Subversion in general so please bear
> with me and point me to wherever my question has been answered before;
> I searched, but without luck ...
>
> After using our svn-repository for some time I suddenly, out of nowhere
> I'd say, get strange file corruptions:
>
> some if not all .svn/entries files all over the repository go
> haywire!
>
> I've uploaded one of the damaged entries-file of our repository's root
> if somebody's interested here:
>
> http://www.uni-koblenz.de/~eyerq/entries
>
> With these damaged enties-files the whole repository is not usable
> anymore, svn constantly fails with
>
> svn: XML parser failed in ''
> svn: Malformed XML: not well-formed (invalid token) at line 1
>
> (which is not amazing given the above entries-files as input I guess
> _any_ XML parser would fail :-/)
>
> Is there anything I can do to fix these entries-files? Is this a known
> bug? Any more information I can provide to help sort things out?

You could help out a little more by providing some more information.
http://svn.collab.net/repos/svn/trunk/BUGS has the details.

Also, have you tried checking out a new working copy? I'd be very
surprised if your repository is unusable. More than likely, it's just
your working copy that's unusable.

If you can give a few more details, perhaps we can figure out what
happened.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Jul 10 23:06:46 2005

This is an archived mail posted to the Subversion Users mailing list.